FIX PROBLEM: Din server kører PHP version, men WordPress 5.1.6 3.2.1 5.2.4 kræver mindst.

Bemærkning til alt er ikke velkendt, at for installere eller lave opgraderingTil den nyere version af 3.2Det er nødvendigt at være installeret en nyere version af 5.2.4.

Hvis serveren er installeret en version af PHP ældre end 5.2.4, installation udgave WordPress 3.2.1Vises fejl / Besked "Din server kører PHP versionen WordPress 5.1.6 3.2.1 Men kræver mindst 5.2.4".
Problemet kan løses meget enkelt ved at opgradere PHP, men før du gør det et par ting bør overvejes. Først, opgradere PHP er muligt på en delt hosting. Så du kan gøre opgraderingen, skal du have administrator adgang til serveren (Dedikeret Server eller VPS). I den anden, bør før opgraderingen dokumentere og være opmærksom på, at ny version af PHP ikke at give fejl andre sites hostet på den server.

for operativsystemet anvendes til webservere (Agreart og / WHM) Vil vise dig, hvordan du gør opgradering til PHP på CentOS 5.2.10.x 5 32-bit.

Opgrader PHP på CentOS 5.1.x 5.2.x til 5.x 32-bit

1. Tjekke, hvilke pakker / moduler er installeret PHP (f.eks php-mcrypt) Foruden standard Packet. Hvis de findes, vil blive slettet eller actuzlizate.

Kontrol installerede pakker:

rpm-qa | grep php

old_php_version

2. At tilføje ekstra repositories Nødvendig opgraderingS PHP versionen.

nano / etc / yum.repos.d / CentOS-Testing.repo

Den nye fil (CentOS-Testing.repo) Vil tilføje følgende linjer (copy / paste):

[C5-test]
name = CentOS-Testing 5
http://dev.centos.org/centos/ baseURL = $ releasever / afprøvning / $ basearch /
aktiveret = 1
gpgcheck = 1
gpgkey = http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing
includepkgs = php *

Ctrl + X at gemme filen CentOS-Testing.repo.

3. Opdatering PHP via yum:

yum update

4. Genstart / httpd :

service httpd restart

Efter genstart httpd og kontrollere versionen af ​​installerede pakker:

new_php_version

Kontrollere for fejl moduler / pakker:

php-v

- PHP Upgrade / CentOS 32-bit (i386).

FIX PROBLEM: Din server kører PHP version, men WordPress 5.1.6 3.2.1 5.2.4 kræver mindst.

Om forfatteren

Stealth LP

Stifter og redaktør Stealth SettingsI 2006 dato.
Erfaring med Linux-operativsystemer (især CentOS), Mac OS X, Windows XP> Windows 10 og WordPress (CMS).

Efterlad en kommentar