Rettelsesfejl: Din PHP-installation ser ud til at mangle den MySQL-udvidelse, der kræves af WordPress

"Din PHP-installation ser ud til at mangle MySQL-udvidelsen, som kræves af WordPress”Er der en fejl, som mange blog- og webstedsejere støder på WordPress.
Dette er ikke en grund til bekymring. Mangel på MySQL-udvidelse fra PHP er typisk for operativsystemer, der er installeret fra bunden, VPS eller dedikerede servere, hvor PHP-udvidelser ikke var en del af installationspakken. Dette problem findes på begge sider Ubuntu og CentOS. I dette scenarie løses problemet meget enkelt med en PHP-opdatering og installationen af ​​modulet "php-mysql".
Opdater PHP og installer MySQL udvidelse på Ubuntu

apt-get update
apt-get install php-mysql

Opdater PHP og installer MySQL-udvidelse på CentOS

yum update
yum install php70w-mysql

Efter dette trin, genstart Apache-tjenesten eller Nginx.

Jeg stødte også på scenariet, hvor skønt MySQL-udvidelsen findes i PHP, en blog oprettet på WordPress viste fejlen "Din PHP-installation ser ud til at mangle den MySQL-udvidelse, som kræves af WordPress". For det meste opstår fejlen, når WordPress installeres. Denne gang optrådte han imidlertid på en blog, der havde været aktiv i flere år.
I denne situation fandt jeg ud af, at problemet ikke var med PHP-modulerne, men med den meget gamle version af WordPress, som ikke længere er kompatibel med PHP 7.4.4RC1. En simpel opgradering af WordPress til den nyeste version løste fejlen.

Rettelsesfejl: Din PHP-installation ser ud til at mangle den MySQL-udvidelse, der kræves af WordPress

Om forfatteren

Stealth

Lidenskabelig over alt gadget og IT, jeg skriver med glæde om stealthsettings.com siden 2006, og jeg kan godt lide at opdage nye ting om computere og operativsystemer macOS, Linux, med dig, Windows, iOS og Android.

Efterlad en kommentar