[Fix phpMyAdmin] Konfigurationen file har nu brug for en hemmelig adgangssætning (blowfish_secret)

Uanset om det er installeret phpMyAdmin server Ubuntu, CentOS eller etc. Fedora distribution, meddelelsen "Konfigurationen file har nu brug for en hemmelig adgangssætning (blowfish_secret)”Med rødt i bunden af ​​indekset, giver det hovedpine. Især når det er konfigureret korrekt i "/etc/phpMyAdmin/config.inc.php".
Stien kan naturligvis variere fra en konfiguration til en anden, men på 7 CentOS cu phpMyAdmin installeret via “yum"Fra"remi.repo", Konfigurationsfilen findes i" / etc / phpMyAdmin / ".

Okay, lad os se, hvordan vi løser det "Konfigurationen file har nu brug for en hemmelig adgangssætning (blowfish_secret)", hvis i config.inc.php vi har denne linje:

$cfg['blowfish_secret'] = 'gNsWq$%#%$#%EDFSsffsegbVp6LCJw6w'; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */

Hvis denne linje er til stede, og vi har en "nøgle" på mere end 32 tegn, skal den røde besked i phpMyAdmin forsvinde.
Hvis dette ikke er sket, er det godt at slette cookies i din browser og logge ud af phpMyAdmin. Ved næste login vises meddelelsen "Konfigurationen file har nu brug for en hemmelig adgangssætning (blowfish_secret)”Han vil ikke længere være til stede.
Selv om der er situationer, hvor det er til stede ikke skyldes fejlkonfigurationer filen config.inc.php, men på grund af mappetilladelserne da han var.

Kør i terminal kommando:

 chown -R root:<user web> /etc/phpMyAdmin/

Nu skal alt være ok. Hvis du bruger Apache, skal du indstille "httpd", "nginx" eller hvordan du har webprocesbrugeren på serveren i stedet for "webbruger".

Jeg skrev disse tip, fordi jeg gennemgik hele phpMyAdmin-konfigurationen i mere end 2 timer, og jeg kan stadig ikke slippe af med beskeden: Konfigurationen file har nu brug for en hemmelig adgangssætning (blowfish_secret). Efter at jeg havde løst tilladelserne / grupperne, forsvandt det.

Stifter og redaktør Stealth Settings, fra 2006 til i dag. Erfaring med Linux-operativsystemer (især CentOS), Mac OS X, Windows XP> Windows 10 og WordPress (CMS).

5 tanker om “[Fix phpMyAdmin] Konfigurationen file har nu brug for en hemmelig adgangssætning (blowfish_secret) ”

  1. Jeg har et sæt leverandørkonfiguration (i /usr/share/phpmyadmin/libraries/vendor_config.php):

    definer ('CONFIG_DIR', '/ etc / phpmyadmin');

    Her er tilbageslag, også så:

    definer ('CONFIG_DIR', '/ etc / phpmyadmin /');

    Danach klappte es auch mit dem Secret

    Svar

Efterlad en kommentar